Back to overview
Degraded

Email delivery disruption (AWS Outage)

Oct 20 at 09:20am CEST
Affected services
Spaak Platform

Resolved
Oct 20 at 12:14pm CEST

Email delivery is now back to normal.
All previously delayed emails — including daily reports and notifications — have been successfully delivered.

The issue was caused by an external service provider outage earlier today, which has now been fully resolved.

Thank you for your patience and understanding while this was being fixed.

Updated
Oct 20 at 11:38am CEST

We’re currently experiencing a delay in the delivery of emails such as daily reports and notifications.
The issue is caused by a broader problem with one of our external service providers, which is now starting to recover.

All emails that were scheduled earlier today have been safely received by our system and will be delivered automatically as soon as the provider is fully back online.

Our platform itself remains fully available and works as normal.
We’ll post another update once everything is back to normal.

Created
Oct 20 at 09:20am CEST

We’re currently experiencing issues with email delivery from our platform due to a major AWS outage, which is also affecting our email provider and several other third-party services.

Our platform remains fully available and operational, but emails such as daily reports and notifications are currently delayed or not being sent.

We’re monitoring the situation closely and will update this page as soon as our third-party providers restore normal service.
All queued emails will be automatically delivered once the issue is resolved.