Back to overview
Downtime

Spaak platform outage caused by Cloudflare global incident

Nov 18 at 12:45pm CET
Affected services
Spaak Platform

Resolved
Nov 18 at 03:50pm CET

Cloudflare has resolved the issue on their side, and the Spaak platform is now fully operational again. All features should be working as expected.

We will continue to monitor system performance closely, but no further disruption is expected.

Thank you for your patience during this incident.

Updated
Nov 18 at 03:40pm CET

Spaak is now mostly accessible again, and many users should be able to use the platform normally.

Cloudflare’s global outage is still ongoing, so some users may still experience occasional slow loading or temporary errors while the situation continues to recover.

We are actively monitoring the situation and will share another update once Cloudflare has fully restored stability.

Created
Nov 18 at 12:45pm CET

We are currently experiencing an issue that is making Spaak slow or unavailable for some users.

This is due to a major technical outage at Cloudflare, a core internet infrastructure provider used by thousands of services worldwide. As a result, parts of the internet — including Spaak — are currently affected.

We are closely monitoring the situation and will share updates as soon as Cloudflare restores stability.

Thank you for your patience — we’ll keep you informed.